nythrix's picture

Cloo 0.8.2 released

Welcome to another maintenance release in the 0.8 series.
This version fixes some discovered bugs affecting extension loading, asynchronous program build, command-queue methods handling ComputeImage2Ds and error checking in some of the ComputeObject.Get*Info methods. It also adds a workaround to prevent Clootils from hanging with the latest Nvidia drivers and another one to help prevent Cloo initialization errors in a multithreaded environment.
New functionality includes support for the cl_ext_device_fission extension.
For the first time ever, Cloo was tested against the Intel OpenCL SDK. Although alpha, Intel's implementation is the first of the lot to successfully pass all the current Clootils tests! Kudos to Intel!
Upgrade from 0.8.1 or 0.8.0 is recommended.

download site


Comments

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
c2woody's picture

Just tried it with the new ATI/AMD drivers, all tests including the image comparison were successful.

nythrix's picture

As far as your rig goes, you're right. I forgot to mention that I don't have an ATI card. Unfortunately, Stream has no image support for the CPU so the relevant test has always failed here (note that Cloo 0.8.2 doesn't actually include the image test because it's still a work in progress). I don't quite get it. It's not like the CPU is a small, helpless embedded device. Also they have AMD's know-how at hand. Meh...

Nvidia does have image support but (officially) misses OpenCL 1.1.

Intel's SDK is not perfect however. It doesn't support 64bit applications. Also I had to tune some register keys to make it work. After all it's an alpha release.

Thanks for testing it out and reporting, though!

c2woody's picture

If you need something tested just ask. Though I can't do that much more than runing examples ;)