altare's picture

First use problems: reference not found

Hello,

First of all I wanted to say thanks to the community for this wondrous tool.

Secondly I am in need of help getting OpenTK to work with the Unity platform:
- I have read,
http://www.opentk.com/doc/chapter/0
but despite the correct installation of the opentk reference, and the correct compilation of my test program, I receive the following error after Unity's recompilation:

The type or namespace name `OpenTK' could not be found. Are you missing a using directive or an assembly reference?

There seems to be a namespace issue of some sort? Whenever I manually build in Mono, I receive no errors and the "Using OpenTK;" statement is in the header.

Any idea of what might be going on?

Thanks.


Comments

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
the Fiddler's picture

By Unity you mean Unity3d? In that case, you'd have to refer to the Unity3d documentation. OpenTK is a full-trust library and I don't know whether the Unity3d allows that (the free edition certainly doesn't).

Do keep in mind that subverting the Unity3d renderer through OpenTK is likely to have unforeseen consequences. Moreover, Unity3d uses Direct3D on Windows, which won't work with OpenTK at all.

altare's picture

Thanks for your reply. But well, my intention is to actually 'launch' OpenTK from unity3d (yes that one), so there'd be no weird tweaking involved, it'd be just like using two separate applications, only with the ability to use a single project since unity works with monodevelop.

In fact, I was hoping to understand what triggers the error. Could it be that OpenTK library uses the default namespace, instead of a named declaration space?