JTalton's picture

OpenTK from SVN has Texture Issues

Project:The Open Toolkit library
Category:bug report

I updated my OpenTK from SVN on WindowsXP and when running my app I see the following.

On the left is the old version, and on the right is the SVN version.

GL.TexImage2D(TextureTarget.Texture2D, 0, PixelInternalFormat.Rgba, textureWidth, textureHeight, 0, PixelFormat.Bgra, PixelType.UnsignedByte, data);
textureWidth and textureHeight are both a power of 2.

Not sure what the issue is, but if I go back to the regular OpenTK and not the SVN, it works fine.


Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
the Fiddler's picture


Status:open» confirmed

Confirmed, the issue is that the TextPrinter thrashes the PixelStore alignment. I'll come up with a fix asap.

the Fiddler's picture


I have commited a fix, can you please test that it works now?

JTalton's picture


Status:confirmed» closed

Works great! Closing issue.

the Fiddler's picture


Status:closed» fixed

Great, thanks for confirming. I hope you don't mind if I mark the issue as "fixed" instead of "closed"? Just doing this for the shake of the changelog: we can conveniently query all fixed issues, build the changelog, then mark them as closed on version e.g. 0.9.2.

Anonymous's picture


Status:fixed» closed

Automatically closed -- issue fixed for two weeks with no activity.

the Fiddler's picture



Closing issues fixed in 0.9.2.