BlueMonkMN's picture

Open GL Version 3 doesn't support 1.2?

I have the following code:

if (!GL.SupportsExtension("VERSION_1_2"))
{
   string errString = "OpenGL version 1.2 is required";
   try
   {
      errString += "; your version is: " + GL.GetString(StringName.Version);
   }
   catch
   {
   }
   throw new ApplicationException(errString);
}

And someone is reporting getting the following error message:
OpenGL version 1.2 is required; your version is: 3.0.0

Why would this be?


Comments

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
the Fiddler's picture

Which version of OpenTK is this? This should work fine since at least OpenTK 0.9.6 (earlier versions did not detect 3.0 contexts correctly).

BlueMonkMN's picture

Looks like I released SGDK 2.1.1 beta 1 with OpenTK 9.1. Guess I should update that.