the Fiddler's picture

[Math] Rename Matrix4.Frustum to CreatePerspectiveOffCenter

Project:The Open Toolkit library
Version:0.9.9-2b
Component:Code
Category:task
Priority:normal
Assigned:Unassigned
Status:closed
Description

For example, Matrix4.Frustum should become Matrix4.CreatePerspectiveOffCenter. This naming scheme is more descriptive and will make XNA ports easier.

The old functions should be marked as obsolete.


Comments

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
the Fiddler's picture

#1

Status:open» postponed

This cannot be implemented in time for 1.0.

the Fiddler's picture

#2

Title:[Math] Rename Matrix4 static methods to follow the XNA API» [Math] Rename Matrix4.Frustum to CreatePerspectiveOffCenter
Version:0.9.x-dev» 0.9.9-2b
Status:postponed» closed

Actually, this specific issue has been implemented already.